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Creating keyframes – creating in-between frames – selecting frames in keyframe spans – 

manipulating frames in one layer – removing frames – making a simple frame-by-frame 

animation – adding keyframe to classic tweens – creating a bouncing ball with shape 

tweening and motion tweening – creating and deleting layers and folders – setting layer 

properties – working with graphics on different layers. 

 

1. CREATING KEYFRAMES 

 Flash offers two commands for creating keyframes. Insert > Timeline > Blank 

Keyframe defines a keyframe that's empty, and Insert > Timeline > Keyframe defines a 

keyframe that duplicates the content of the preceding keyframe in that layer. Use the Insert > 

Timeline > Blank Keyframe command when you want to change the contents of the Stage 

completely. Use Insert > Timeline > Keyframe when you want to duplicate the content of the 

preceding keyframe. 

 

To add a blank keyframe to the end of your movie 

1. Create a new Flash document. 

The new document by default has one layer and one blank keyframe at frame 1. 

2. In the Timeline, click the protoframe for frame 10 to select it. 

3. Choose Insert > Timeline > Blank Keyframe (Figure 8.4). 

 



Figure 8.4. Select a frame in the Timeline (top) and then choose Insert > Timeline > 

Blank Keyframe (middle) to add a new blank keyframe (bottom). 

 

 Flash revises the Timeline to give you information about the frames you've defined. A 

hollow rectangle appears in frame 9, and a black line separates frame 9 from frame 10. This 

line indicates where the content for one keyframe span ends and the content for the next 

keyframe begins. Flash replaces the gray bars separating protoframes 29 with gray tick marks 

and removes the gray highlight that appeared in every fifth frame of the undefined frames. 

To create a blank keyframe in the middle of your movie 

1. Follow the steps in the preceding task to create a single-layer, 10-frame movie. 

2. In the Timeline, click frame 1 to select it. 

3. Draw a shape on the Stage. 

Flash updates the Timeline, adding a solid bullet to frame 1 (Figure 8.5). 

Figure 8.5. When you place content in a keyframe, Flash displays that frame in the 

Timeline with a solid bullet. The gray tint on the frames between keyframes indicates 

that content from the preceding keyframe appears during these frames. The hollow 

square indicates the end of the span of in-between frames displaying the same content. 

The hollow circle indicates a blank keyframe. 

 

With Tinted Frames selected in the Frame View menu (Flash's default setting), Flash shades 

frames 19 with gray. The shading indicates that keyframe 1 has content that remains visible 

until frame 10 in this layer. A hollow rectangle appears in frame 9, indicating the end of the 

span of in-between frames that displays the content of keyframe 1. 

Frame 10 still contains a hollow bullet, meaning that it has no content. (Try clicking frame 10 

to see that the Stage is blank.) 

4. In the Timeline, in the area above the layers, click the number 5 or drag the playhead to 

position it in frame 5. 



 

Flash displays frame 5 on the Stage. Notice that this in-between frame continues to 

display the content of the preceding keyframe, frame 1. 

5. Choose Insert > Timeline > Blank Keyframe. 

 

Flash converts the selected in-between frame to a keyframe and removes all content from 

the Stage in that frame (Figure 8.6). 

Figure 8.6. When you convert an in-between frame that displays content to a blank 

keyframe, Flash removes content from the Stage for that frame. Frames 69 are tinted 

when they display the content of frame 1 (top). When you insert a blank keyframe at 

frame 5 (bottom), the tint disappears, because these frames now display the content of 

the most recent keyframe, frame 5, which is empty. 

 

To duplicate the contents of the preceding keyframe 

1. Follow steps 13 in the preceding task. 

You should have a document with content in keyframe 1. 

2. In the Timeline, select frame 3. 



The playhead doesn't move into the protoframe area, but frame 3 is highlighted as the 

current selected frame. 

Choose Insert > Timeline > Keyframe. 

 

Flash creates a new keyframe, duplicates the contents of frame 1 in frame 3, and places a 

solid bullet in the Timeline at frame 3 and a hollow rectangle in frame 2 (Figure 8.7). The 

content of frames 1 and 3 is totally separate. Try selecting frame 1 and making changesmove 

the graphic or delete it. Now select frame 3 again; it remains unchanged. 

Figure 8.7. The Insert > Timeline > Keyframe command creates a keyframe that 

duplicates the contents of the preceding keyframe in that layer. 

 

 

2. CREATING IN-BETWEEN FRAMES 

The frames that appear between keyframes are in a sense tied to the keyframe that precedes 

them. They display its content and allow you a space in which to create tweened animation 

(see Chapters 9 and 10). Flash makes the connections between these frames clear by 

highlighting them and placing a hollow rectangle at the end of the keyframe span. 

To add in-between frames 

1. Open or create a Flash document with keyframes and content in frame 1 and frame 2. 

2. In the Timeline, position the playhead in keyframe 1. 

3. Choose Insert > Timeline > Frame, or press F5 on the keyboard (Figure 8.8). 



Figure 8.8. Choose Insert > Timeline > Frame to add in-between frames to the 

Timeline. 

 

Flash adds an in-between frame (Figure 8.9). Your movie now contains a keyframe at 

frame 1, an in-between frame at frame 2, and another keyframe at frame 3. 

Figure 8.9. The Insert > Timeline > Frame command adds an in-between frame 

after the selected frame. Unlike Insert > Timeline > Keyframe and Insert > Timeline 

> Blank Keyframe, which convert a selected in-between frame or protoframe to a 

keyframe, the Insert > Timeline > Frame command adds a new frame to your 

movie. 

 

 

In Flash, you must use keyframes to define any change in the content or image, no matter 

how large or small the change. Flash doesn't use the term in-between frames; it uses the 

term frame for any frames that aren't defined as keyframes. For clarity, the tasks in this book 

use the term in-between frames to refer to any defined frames that aren't keyframes. 

 

 



 

 

3. SELECTING FRAMES IN KEYFRAME SPANS 

              Flash offers two styles for selecting frames in the Timeline. The default selection 

style, frame-based selection, treats every frame as an individual. The span-based style treats 

frames as members of a keyframe spanthe keyframe plus any in-between frames that follow it 

and display its content. In the span-based selection style, clicking one frame in the middle of 

a span selects the entire span. 

               Except where noted, the examples in this book use Flash's default selection style, 

frame-based selection. 

To choose a selection style 

1. From the Edit menu (Windows) or from the Flash application menu (Mac), choose 

Preferences. 

The Preferences dialog appears. 

2.  From the Category list, select General.The General settings appear in the right-hand pane 

of the dialog (Figure 8.10). 

Figure 8.10. Choose the way frame selection works in the Timeline from the General 

category of the Preferences dialog. 

 

3. In the Timeline section, choose either of the following frame-selection styles: 

o To manipulate keyframe spans in the Timeline, select the Span Based Selection 

check box. 

o To manipulate individual frames in the Timeline, deselect the Span Based 

Selection check box. 

To make frame-based selections 

In the Timeline, do one of the following: 



o To select one protoframe, click it. 

o To select two protoframes and all the frames between them, Shift-click the two 

protoframes. 

o To select a keyframe, click it. 

o To select the last frame in a keyframe span, click it. 

o To select just a middle frame in a keyframe span, click that frame. 

o To select an entire keyframe span, double-click a middle frame in the keyframe span. 

o To add frames to your selection, Shift-click the frames. Flash selects all the frames 

between the playhead and the frame you Shift-click. 

o To select a range of frames, click and drag through the frames. 

To make span-based selections 

In the Timeline, do one of the following: 

o To select one protoframe, click it. 

o To select two protoframes and all the frames between them, Shift-click the two 

protoframes. 

o To select a keyframe, click it. 

o To select the last frame in keyframe span, click it. 

o To select one in-between frame, -click (Mac) or Ctrl-click (Windows) that frame. 

o To select an entire keyframe span, click a middle frame in the keyframe span. 

o To select an entire keyframe span, Shift-click the first or last frame in the span. 

o To add other spans to your selection, Shift-click the spans. The selection can include 

noncontiguous spans (Figure 8.11). 

Figure 8.11. With Flash's span-based frame-selection style, you can Shift-click to 

select keyframe spans that aren't contiguous. 

 

 

o To select a range of frames in the Windows operating system, Ctrl-drag through the 

frames. 

4. MANIPULATING FRAMES IN ONE LAYER 

 You can't copy or paste frames by using the standard Copy and Paste commands that 

you use for graphic elements. Flash's Edit menu provides special commands for copying and 

pasting frames. Flash also lets you drag selected frames to new locations in the Timeline. 



For the following tasks, open a new Flash document. Create a 10-frame movie with 

keyframes at frames 1, 3, 5, and 9. Using the text tool, place a text box in each keyframe, and 

enter the number of the frame in the text box; this technique makes it easy to tell what frame 

winds up where as you practice. Your document should look like Figure 8.13. 

 Figure 8.13. To practice moving frames around, create a document with 

keyframes at frames 1, 3, 5, and 9. Each keyframe contains a text box with the number 

of the frame. 

    

To copy and paste a single frame 

1. In the Timeline, select keyframe 3. 

2. Choose Edit > Timeline > Copy Frames, or press Option- -C (Mac) or Ctrl-Alt-C 

(Windows) (Figure 8.14). 

Figure 8.14. Flash's Edit menu provides special commands for copying and pasting 

frames in the Timeline. 

 

 

Flash copies the selected frame to the clipboard. 

3. In the Timeline, click frame 4 to select it as the location for pasting the copied frame. 

4. Choose Edit > Timeline > Paste Frames, or press Option- -V (Mac) or Ctrl-Alt-V 

(Windows). 



Figure 8.15. When you paste a frame with new content into an in-between frame, 

Flash converts the frame to a keyframe. 

 

5. Paste another copy into frame 5 (Figure 8.16). 

Figure 8.16. When you paste a frame with new content into a keyframe, Flash 

replaces the keyframe's content. 

 

Flash replaces the contents of keyframe 5 with the content of keyframe 3. 

6. Paste another copy into protoframe 12. 



 Flash extends the movie to accommodate the pasted frame. Note that the playhead won't 

move to protoframe 12 until after you've pasted the copy to create a defined frame. 

5. REMOVING FRAMES 

 Flash has two commands for removing frames: Clear Keyframe and Remove Frames. 

To choose the correct command, ask yourself whether you want to eliminate the frame and 

reduce the length of the movie or just remove the frame's status as a keyframe, keeping the 

same total number of frames. 

 Flash's Clear Keyframe command removes keyframe status from a selected frame or 

range of frames. Clear Keyframe changes keyframes into in-between frames and deletes the 

keyframes' content from the movie. Clear Keyframe has no effect on the number of frames in 

the movie. 

 Remove Frames removes frames (and their content, if they're keyframes) from the 

movie. Remove Frames reduces the number of frames in the movie. 

 For the following tasks, use the same practice document you created for working with 

the tasks in "Manipulating Frames in One Layer." 

To remove keyframe status from a frame 

1. In the Timeline, select keyframe 5. 

2. Choose Modify > Timeline > Clear Keyframe, or press Shift-F6 on the keyboard. 

 Flash removes the bullet from frame 5 in the Timeline (indicating that the frame is no 

longer a keyframe) and removes the graphic element it contained. Frame 5 becomes an in-

between frame, displaying the contents of the keyframe at frame 3 (Figure 8.18). The total 

number of frames in the movie remains the same. 

 



 

Figure 8.18. The Modify > Timeline > Clear Keyframe command removes the contents 

of the selected keyframe from the Stage and converts the keyframe to an in-between 

frame. The Clear Keyframe command doesn't change the overall length of the movie. 

To delete a single frame from a movie 

1. With your practice file in its original state (keyframes at 1, 3, 5, and 9), select frame 4 in 

the Timeline. 

Frame 4 is an in-between frame associated with keyframe 3. 

2. Choose Edit > Timeline > Remove Frames, or press Shift-F5 on the keyboard. 

Flash deletes frame 4, reducing the overall length of the movie by one frame (Figure 

8.20). 

Figure 8.20. The Edit > Timeline > Remove Frames command removes frames from 

the movie and reduces its length. 

 

3. Select keyframe 3 and choose Edit > Timeline > Remove Frames again. 

Flash deletes the selected keyframe and its content, and reduces the length of the movie 

by one frame. 



To delete a range of frames 

1. Using your practice file, in the Timeline, select frames 36. 

2. Choose Edit > Timeline > Remove Frames. 

Flash removes all the selected frames (Figure 8.21). 

 

Figure 8.21. The Edit > Timeline > Remove Frames command can delete a selected 

range of frames. Because an entire keyframe span (frames 3 and 4) is included in the 

selection (top), Flash not only reduces the number of frames but also removes the 

content of that keyframe span (middle). Where only part of a span was selected (frames 

5 and 6), the span gets shorter, but the content remains the same (bottom). 

 

 



6. MAKING A SIMPLE FRAME-BY-FRAME ANIMATION 

 In traditional cel animation or flip-book animation, you create the illusion of 

movement by showing a series of images, each slightly different from the rest, simulating 

snapshots of the movement. When you create each of these drawings and place them in a 

series of keyframes, that process is called frame-by-frame animation. When you create only 

the most crucial snapshots and allow Flash to interpolate the minor changes that take place 

between those snapshots, you're creating tweened animation.  

 A classic example of frame-by-frame animation is a bouncing ball. You can create a 

crude bouncing ball in just three frames. 

To set up the initial keyframe 

1. Create a new Flash document, and name it something like Frame-by-Frame Bounce. 

By default, Flash creates a document with one layer and a keyframe at frame 1. Choose 

View > Grid > Show Grid to help you reposition your graphics in this task. 

2. IntheTimeline,selectkeyframe1. 

Use the Frame View pop-up menu to set the Timeline to Preview in Context mode. This 

setting makes it easy to keep track of what you do in the example. 

3. In the Tools panel, select the oval tool. 

4. Set the stroke color to No Color. 

5. Near the top of the Stage, draw a circle (Figure 8.22). 

 

Figure 8.22. In keyframe 1, draw a circle near the top of the Stage. This circle will 

become a bouncing ball. 

 

To create the second keyframe 

1. In the Timeline, select frame 2. 



2. Choose Insert > Timeline > Keyframe. 

Flash creates a keyframe in frame 2 that duplicates your ball from keyframe 1. 

3. In keyframe 2, select the ball and reposition it at the bottom of the Stage (Figure 8.23). 

  

Figure 8.23. Use the Insert > Timeline > Keyframe command to duplicate the ball from 

keyframe 1 in keyframe 2. Then drag the ball to reposition it. 

 

 



To create the third keyframe 

1. In the Timeline, select frame 3. 

2. Choose Insert > Timeline > Keyframe. 

Flash creates a keyframe in frame 3 that duplicates your ball from keyframe 2. 

3. In keyframe 3, select the ball and reposition it in the middle of the Stage (Figure 8.24). 

Figure 8.24. Use the Insert > Timeline > Keyframe command to duplicate the ball from 

keyframe 2 in keyframe 3. Drag the ball to reposition it again. 

 



7. ADDING KEYFRAME TO CLASSIC TWEENS 

 

 Classic Tweens are used to transition between two symbol states. In other words, you 

may have a symbol at stage left, at frame one, and the same symbol at stage right at frame 20. 

Once you apply a Classic Tween, the object gradually moves from left to right over 20 

frames. 

 In addition to Position, you can also tween Tint, Rotation, Alpha, Brightness, and 

Scale. It is best to convert your object to a symbol before applying a tween. 

Classic Tweens require that you have one symbol at the start keyframe and that same symbol 

in a end keyframe. There must be some change made to the symbol state (i.e., Position or 

Alpha), in the end keyframe. 

 For information on Alpha, Brightness or Tint tweening, see topics Transparency 

(Alpha) Tween, Brightness Tween, and Tint Tween. 

 Step One 

 Add an oval shape to the stage using the Oval tool (o key). 

Step Two 

 With the oval shape selected, convert it to a Movie Symbol (F8)(Modify > Convert to 

Symbol). 

Step Three 

 Click frame 20 of and press F6 (Insert > Timeline > Keyframe). The contents of 

frame one is copy-pasted into the newly created keyframe at frame 20. 

Step Four 

 Click the keyframe at frame 1. Using the Selection tool (v key), then click and drag 

the oval to a new position. 

Step Five 

 Right-click the timeline between your keyframes and choose Create Classic Tween 

from the pull-down menu. 

http://pixelstreetstudios.com/flash/flash-cs4-topics/transparency-alpha-tween/
http://pixelstreetstudios.com/flash/flash-cs4-topics/transparency-alpha-tween/
http://pixelstreetstudios.com/flash/flash-cs4-topics/brightness-tween/
http://pixelstreetstudios.com/flash/flash-cs4-topics/tint-tween/


Step Six 

 To render your swf file, press Cmd/Return (PC-Ctrl/Enter). 

 Motion Tweens and Shape Tweens 

 Classic Tweens work with Symbols. If you wish to transition between Drawing 

Objects or Merge Shapes you would use a Shape Tween. 

Dashed Tweens are a Bad Thing 

 Dashed tweens tell you that something is wrong. For instance, if you assigned a 

motion tween between two keyframes, one with a symbol and the second one empty, the 

tween would appear as a dashed line. 

 

8. CREATING A BOUNCING BALL WITH SHAPE TWEENING  

             Although shape tweens can animate changes in many properties of graphicscolor, 

size, locationthe distinguishing function of shape tweening is to transform one shape into 

another. You could use a shape tween to replicate the simple bouncing-ball animation you 

created in Chapters 8 and 9, but the beauty of shape tweening is that it lets you change the 

shape of the ball. A better use of shape tweening for a bouncing ball is to flatten the ball as it 

strikes the ground. 

To define shape tweens via the Frame Properties tab of the Property inspector 

1. In a new Flash document, or in a new layer of an existing document, position the 

playhead in frame 1. 

2. In the Tools panel, choose the oval tool. 

3. Set the stroke to No Color. 

4. Near the top of the Stage, draw a circle. 

This circle will be the ball. Make it fairly large. 

5. In the Timeline, select frame 5, and choose Insert > Timeline > Keyframe. 

The Insert > Timeline > Keyframe command makes a new keyframe that duplicates the 

contents of the preceding keyframe. 

6. Select frame 10, and choose Insert > Timeline > Keyframe. 
 

7. In frame 5, select the ball, and drag it to the bottom of the Stage. 

Now you have the keyframes necessary to make a simple bouncing ball like the one in 

the motion-tween task. In frame 1, the ball is at the top of its bounce; in frame 5, the ball 

is at the bottom of its bounce; and in frame 10, the ball is back up at the top. 

8. Use the drawing tools to reshape the oval in frame 5, flattening the bottom and 

elongating it a bit sideways (Figure 10.1). 



 

 

By changing the shape at the bottom of the bounce, you make it look like the ball really 

contacts something solid, such as a floor. 

9. To define the shape tween for the first half of the ball's bounce, in the Timeline, select 

any of the frames in the first keyframe span (1, 2, 3, or 4). 

Note that the ball is selected automatically. When you define a shape tween, the element 

to be tweened must be selected. 

10. In the Frame Properties tab of the Property inspector, from the Tween pop-up menu, 

choose Shape. 

The settings for the shape tween appear (Figure 10.2). 

 

Flash creates a shape tween in frames 14 and color-codes those frames in the Timeline. With 

Tinted Frames active (choose it from the Frame View pop-up menu at the end of the Edit 

Bar), Flash applies a light green shade to the frames containing a shape tween. If Tinted 

Frames is inactive, the frames are white (Mac) or patterned (Windows), but Flash changes the 

arrow that indicates the presence of a tween from black to green. 

11. In the Ease field, do one of the following: 

o To make the bounce start slowly and speed up, enter a negative value. 



o To make the bounce start quickly and slow down, enter a positive value. 

o To keep the bounce constant, enter 0. 

12. From the Blend menu, choose either of the following options: 

o To preserve sharp corners and straight lines as one shape transforms into another, 

choose Angular. 

o To smooth out the in-between shapes, choose Distributive. 

13. To define the shape tween for the second half of the ball's bounce, in the Timeline, select 

any of the frames in the second keyframe span (5, 6, 7, 8, or 9). 

14. Repeat steps 1012. 

Flash creates the second half of the ball's bounce with another shape tween (Figure 10.3). 

 

 

 

 



9. CREATING A BOUNCING BALL WITH MOTION TWEENING 

 Flash provides a special command, Create Motion Tween, that helps you through the 

steps of making a motion tween. The Create Motion Tween command makes sure that you 

have symbols in your tweens and a keyframe at both the beginning and end of the tween 

sequence. 

To use the Create Motion Tween command: 

1. Create a new Flash document, and name it something like Motion Tween Bounce. By 

default, Flash creates a document with one layer and a keyframe at Frame 1. 

2. In the Timeline, select Frame 1. 

3. In the Toolbox, choose the oval tool, and set the stroke to No Color . 

4. Near the top of the Stage, draw a circle. This circle will be the ball. Make it fairly 

large. 

5. With Frame 1 still selected, from the Insert menu, choose Create Motion Tween 

(Figure 9.1). 

Figure 9.1. Choose Insert > Create Motion Tween to start the tweening process. 

 

Flash creates a symbol from the graphics on the Stage. Flash gives the symbol a default name 

based on the number of tweening graphics already created in the movie. In this case, Flash 

turns the ball into a symbol named Tween 1 (Figure 9.2). 

 



6. In the Timeline, select Frame 5. 

7. Choose Insert > Frame. 

Flash adds frames containing a dotted line (Figure 9.3). The dotted line indicates that 

these frames are set to contain a motion tween, but something is wrong, and Flash 

cannot complete the tween. In this case, the keyframe that describes where the ball 

should be at the end of this animation sequence is missing. 

 

8. In Frame 5, move the circle to the bottom of the Stage to create the downward bounce of 

the ball. 

Flash creates a keyframe in Frame 5 with the symbol located at the bottom of the Stage. Then 

Flash updates the Timeline to give you information about the tween. In the in-between frames 

that contain the motion tween, Flash replaces the dotted line with an arrow, indicating that 

tweening takes place in these frames (Figure 9.4). These in-between frames are still "empty," 

in the sense that they have no content on the Stage that you can edit. They no longer display 

the content of the preceding keyframe, but they display the incrementally changed content 

that Flash creates. 

 



9. In the Timeline, select Frame 10. 

10. Choose Insert > Frame. 

Flash extends the motion-tween tinting to Frame 10. A dotted line indicating an 

incomplete tween appears in Frames 6 through 10. 

11. In Frame 10, move the circle to the top of the Stage to create the upward bounce of 

the ball. 

Flash creates a new keyframe to contain the changed content and puts the tweening 

arrow over the in-between frames (Figure 9.5). 

 

12. From the Control menu, choose Play to preview the animation. 

 

10. CREATING AND DELETING LAYERS AND FOLDERS 

To add layers and folders 

1. In the Timeline, select a layer or folder layer. 

Flash always adds the new layer or folder directly above the one you selected, so be sure 

to select the layer or folder that should wind up directly beneath the new one. To add a 

layer or folder beneath the current bottom layer, create the layer first, and then click and 

drag it to reposition it at the bottom of the stack. 

2. To add a layer, do either of the following: 



o Choose Insert > Timeline > Layer (Figure 6.2). 

o Figure 6.2. Choose Insert > Timeline > Layer to add a new layer to the Timeline. 

 

o In the Timeline, click the Insert Layer button. 

Flash adds a new layer and gives it a default namefor example, Layer 4 (Figure 6.3). 

Figure 6.3. Select the layer that you want to wind up beneath the new layer (top); Flash 

inserts a new layer directly above the selected layer and gives the new layer a default 

name (bottom). 

 

You can add new layers and layer folders as you need them while creating the ingredients of 

a particular scene in your movie. 

3. To add a folder, do either of the following: 

o Choose Insert > Timeline > Layer Folder. 

o In the Timeline, click the Insert Layer Folder button. 

Flash adds a new layer folder and gives it a default namefor example, Folder 1 or Folder 

2 (Figure 6.4). 

Figure 6.4. Select the layer that should be below the new folder (top). Flash creates a 

new folder above the layer you selected (bottom). Flash names new folders based on 

the number of folders that have been created in the current scene of the movie. 



 

 

Flash bases the number in the default names on the number of layers or folders already 

created in the active scene of the movie, not on the number of layers and folders that 

currently exist. Flash tracks layer and folder numbers separately; the first folder you 

insert among numerous layers gets the name Folder 1. 
 

 

To delete layers or folders 

1. In the Timeline, select the layer or folder you want to delete. 

2. Click the Trash icon (Figure 6.5). 

Figure 6.5. Click the Trash icon to delete a selected layer or folder. 

 

Flash removes that layer (and all its frames) or that folder (and all the layers it contains) 

from the Timeline. 

To delete multiple layers and/or folders 

1. In the Timeline, select the first layer or folder you want to remove. 

2. -click (Mac) or Ctrl-click (Windows) every layer or folder you want to remove. 

 

This method of selection allows you to choose multiple layers that aren't contiguous 

(Figure 6.7). 

Figure 6.7. To delete noncontiguous layers, -click (Mac) or Ctrl-click (Windows) 

the layers you want to add to your selection; then click the Trash icon. 



 
3. Click the Trash icon. 

 

Flash removes the selected layers (and their frames) from the Timeline. 

 

If your selection includes folders containing layers, a dialog appears, warning that 

deleting the layer folder will also delete all the layers it contains. 

4. To delete the folder and its layers, click Yes. 

 

or 

 

To cancel the delete operation, click No. 

 

11. SETTING LAYER PROPERTIES 

 General—Used to record a layer description, set credits ,and specify scale-dependent 

drawing properties. 

 Source—Allows you to view the extent of your data. You can view and change the 

source of your data from this tab. 

 Selection—Allows you to set how features in a specific layer are highlighted when 

they are selected. Selection property changes in a specific layer override the 

default Selection Options settings. 

 Display—Controls how your data is displayed as you move in the view. Options 

include making a layer transparent, adding MapTips and hyperlinks, and restoring 

excluded features. 



 Symbology—Provides options for assigning map symbols and rendering your data. 

Options include drawing all features with one symbol; using proportional symbols; 

using categories based on attribute values; the use of quantities, color ramps, or charts 

based on attributes; or the use of representation rules and symbols. 

 Fields—Used to set characteristics about attribute fields. You can also create aliases, 

format numbers, and make fields invisible. An important aspect is to set Alias names 

for visible fields that make it easier for your users to work with feature attributes. 

 Definition Query—Allows you to specify that a subset of your features will be used 

in the layer. With the Query Builder dialog box, you can create an expression to 

select particular features of a dataset to be used in your layer. 

 Labels—Allows you to turn on a layer's labels, build label expressions, manage label 

classes, and set up the labeling options for label placement and symbology. 

Alternatively, you can set labeling properties for all layers within the map using 

the Label Manager. 

 Joins and Relates—Allows you to join or relate attribute tables to the layer's feature 

attribute table. 

 Time—Used to specify the time properties of time-aware layers. 

 HTML Popup—Used to specify how pop-up lists are generated when you click a 

feature to display information about it. 

 

13. WORKING WITH GRAPHICS ON DIFFERENT LAYERS 

          Unless you lock shapes, or lock or hide layers, the graphics on all layers are available 

for editing, but you can add shapes only to the active layer (the one that's currently selected). 

You can use any of the techniques you learned in Chapter 4 to modify merge-shapes and 

drawing-objects. 

To activate a layer 

o To select the layer where you want to add a graphic-object, do either of the following: 

o In the Timeline, click the layer name. 

 

The area containing the layer name highlights and a pencil icon appears to the 

right of the layer name. Flash selects all the graphic-objects on that layer. 

o On the Stage, click a graphic-object. 

 

Flash selects that graphic-object and highlights the layer name as described 

above. 

To edit shape outlines on inactive layers 

1. In a document with shapes on two or more layers, using the selection tool, position the 

pointer over a shape on an inactive layer (one without the pencil icon). 

 

https://desktop.arcgis.com/en/arcmap/10.3/map/working-with-text/the-label-manager.htm
https://desktop.arcgis.com/en/arcmap/10.3/map/time/using-time-information-from-a-data-source.htm


The curve or corner-point icon appears. 

2. Drag the outline of the shape on the inactive layer. 

3. Release the mouse button. 

Flash redraws the shape (Figure 6.20). The layer that was active originally remains active. 
 

 

Figure 6.20. Oval is the active layer, but you can still edit shapes on inactive layers. 

Modifying a shape's outline with the selection tool doesn't activate the shape's layer.  

 

To edit fills across layers 

1. In a document with shapes on two or more layers, select the paint-bucket tool from the 

Tools panel. 



2. From the Color Mixer panel, choose a new color. 

3. Position the paint-bucker over a shape on an inactive layer and click. 

Flash fills the shape with the new color, but the layer remains inactive (Figure 6.21). 

 

Figure 6.21. Using the paint-bucket tool to change a fill color on an inactive layer 

doesn't activate that layer. 

 

 

 

 


	To add a blank keyframe to the end of your movie
	Figure 8.4. Select a frame in the Timeline (top) and then choose Insert > Timeline > Blank Keyframe (middle) to add a new blank keyframe (bottom).

	To create a blank keyframe in the middle of your movie
	Figure 8.5. When you place content in a keyframe, Flash displays that frame in the Timeline with a solid bullet. The gray tint on the frames between keyframes indicates that content from the preceding keyframe appears during these frames. The hollow s...
	Figure 8.6. When you convert an in-between frame that displays content to a blank keyframe, Flash removes content from the Stage for that frame. Frames 69 are tinted when they display the content of frame 1 (top). When you insert a blank keyframe at f...

	To duplicate the contents of the preceding keyframe
	Figure 8.7. The Insert > Timeline > Keyframe command creates a keyframe that duplicates the contents of the preceding keyframe in that layer.

	To add in-between frames
	Figure 8.13. To practice moving frames around, create a document with keyframes at frames 1, 3, 5, and 9. Each keyframe contains a text box with the number of the frame.

	To copy and paste a single frame
	To remove keyframe status from a frame
	Figure 8.18. The Modify > Timeline > Clear Keyframe command removes the contents of the selected keyframe from the Stage and converts the keyframe to an in-between frame. The Clear Keyframe command doesn't change the overall length of the movie.

	To delete a single frame from a movie
	To delete a range of frames
	Figure 8.21. The Edit > Timeline > Remove Frames command can delete a selected range of frames. Because an entire keyframe span (frames 3 and 4) is included in the selection (top), Flash not only reduces the number of frames but also removes the conte...

	To set up the initial keyframe
	Figure 8.22. In keyframe 1, draw a circle near the top of the Stage. This circle will become a bouncing ball.

	To create the second keyframe
	To create the third keyframe
	Figure 8.24. Use the Insert > Timeline > Keyframe command to duplicate the ball from keyframe 2 in keyframe 3. Drag the ball to reposition it again.

	Step Two
	Step Three
	Step Four
	Step Five
	Step Six
	Dashed Tweens are a Bad Thing
	Figure 9.1. Choose Insert > Create Motion Tween to start the tweening process.

	To add layers and folders
	o Figure 6.2. Choose Insert > Timeline > Layer to add a new layer to the Timeline.

	To delete layers or folders
	To delete multiple layers and/or folders
	Figure 6.20. Oval is the active layer, but you can still edit shapes on inactive layers. Modifying a shape's outline with the selection tool doesn't activate the shape's layer.

	To edit fills across layers
	Figure 6.21. Using the paint-bucket tool to change a fill color on an inactive layer doesn't activate that layer.




